HTH-C.com - Forum
Latest News Latest Threads
Neuerung: Persönliche Galerie
Informationen zur Übernahme der Erweite..
HTH Blog - Version 2.0
#HTH.Systems - Betatester gesucht
Neueröffnung - PHPKit-Award.de
HTH Webchat v3
Letzter Beitrag Happy Birthday Bottyline Weiblicher Benutzer Heute, 0:00 Zeit der letzten Antwort
Letzter Beitrag Gibt es eigentlich noch jemand der PHPki.. Dooki Männlicher Benutzer 16.07.2024 - 20:47 Zeit der letzten Antwort
Letzter Beitrag PHPKit 1.6.6 WEBI Männlicher Benutzer 24.06.2024 - 13:58 Zeit der letzten Antwort
Letzter Beitrag Herzlich Willkommen Botty Männlicher Benutzer 07.06.2024 - 02:42 Zeit der letzten Antwort
Letzter Beitrag PHPKit 1.6.6 ohne ASCE auf PHP8x Myrddin Männlicher Benutzer 22.03.2023 - 13:36 Zeit der letzten Antwort
 54.227 Posts & 4.945 Themen in 78 Foren
Forenübersicht » Support / Hilfe » PHPKit 1.6.4 & 1.6.5 & 1.6.6 » Support » Cookie Bar setzen.

Cookie Bar setzen.
14 Beiträge in diesem Thema
 Seiten (1):    1  
19.11.2015 - 16:48 Uhr
Beitrag: #1
Hallo Webi und Freunde des Kits

Ich habe folgendes Problem. Ich hab gelesen dass man einen Cookieverweis auf seine HP machen muss.
Habe mir den Code von der HP genommen.

Nun wollte ich ihn in die Vorlagen/site einfügen und bekam folgende Meldung im Adminbereich:
Forbidden

You don't have permission to access /pk/include.php on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Hatte ich bisher nie. Hab dann den Ordner "pk" mit allen Unterordnern über FTP ein 777 Rechte vergeben aber das Problem bleibt....

Hat jemand eine Lösung?
PS: Im PHPKIT SecurityModule habe ich PKSM Schutz deaktiviert gehabt weil sonst geht es ja garnicht.

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Nueschtmanescht - 19.11.2015 - 16:49 Uhr
 
Zum Anfang der Seite
19.11.2015 - 18:04 Uhr
Beitrag: #2
Kommt das nur wenn du die Template-Vorlage site bearbeiten möchtest? Rufst du die Vorlage site vom jeweilgen Style oder die vom FTP-Server (über den Adminbereich) auf?  


 
Zum Anfang der Seite
22.11.2015 - 19:19 Uhr
Beitrag: #3
Hallo
Ich rufe die Site über die Vorlage im Adminbereich auf. Ging sonst immer.

 
Zum Anfang der Seite
23.11.2015 - 16:54 Uhr
Beitrag: #4
Und gehen andere Vorlagen / Templates im Adminbereich?

Nun ja, egal. Kann im Grunde entweder ein Login-Fehler sein (warum auch immer) oder im Ordner pk/ ist eine .htaccess-Datei, die irgendwelche Regeln hat  

Du kannst, wenn das Problem nicht behoben wird, die CookieBar auch anderweitig einpflegen.
Gehe dazu in Adminbereich > Konfiguration > Meta-Angaben. Hier findet sich ein Eingabefeld für Eigene Headerangaben. Dort kannst du als letzten Eintrag den Code auch eingeben.

Wär jetzt zwar keine Lösung für die Bearbeitung von Vorlagen / Templates, aber ich glaube dir reicht es wenn die CookieBar gesetzt ist ^^"


 
Zum Anfang der Seite
24.11.2015 - 15:00 Uhr
Beitrag: #5
Das funktioniert leider auch nicht. Gleiche Meldung.
Ich habe schon lange nichts mehr in den Templates ändern müssen und habe auch schon eine weile nichts geändert. Ich verstehs nicht. Kann es sein dass mein Provider etwas in den Einstellungen geändert hat?

 
Zum Anfang der Seite
24.11.2015 - 16:47 Uhr
Beitrag: #6
Kommst du überhaupt in den Adminbereich? Wenn ja, wie weit kommst du denn? Kannst du Eingaben tätigen, oder Buttons (z.B. Speichern, Editieren, Löschen etc.) anklicken?

Hast du denn mal geguckt ob im Ordner pk/ ein .htaccess-Datei ist? Dort ist normalerweise keine.

Und ja, der Provider könnte Änderungen durchgeführt haben. Bin mir aber nicht sicher inwieweit diese Einfluss haben könnten. So im groben könnte vielleicht die PHP- oder MySQL-Version geändert worden sein. Kann mir aber nicht vorstellen das solche Änderungen nur den Adminbereich beeinflussen, geschweige solche Meldungen verursacht  


 
Zum Anfang der Seite
28.11.2015 - 18:58 Uhr
Beitrag: #7
Hallo
Ich kann Beiträge schreiben, kann alles im Adminbereich anklicken was man normalerweise so braucht. Nur der Rest funzt nicht. Ich hab keine ht.access Datei im Ordner pk.

Andere Vorlagen funktionieren, nur die site Vorlage nicht.

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von Nueschtmanescht - 28.11.2015 - 19:02 Uhr
 
Zum Anfang der Seite
01.12.2015 - 16:48 Uhr
Beitrag: #8
Hmm, ich hatte mal in anderen Foren nach ähnlichen Problemen geguckt.

Bei einen meinte das man mal die Error-Log-Datei mal durchgucken sollte.
Problem:
Nicht alle Anbieter bieten die Möglichkeit diese Datei zu öffnen.

Hier wird beim 2. Punkt beschrieben wo die Datei ist.
Zitat
Wo finde ich das Error-Log?

Das Error-Log ist über FTP abrufbar und liegt im Ordner "log" mit dem Dateinamen "error_log":

/log/error_log

Diese Datei wird regelmäßig rotiert, archivierte Dateien finden Sie im Ordner "/log/old".



Vielleicht hast ja Zugriff und kannst darin mal gucken. Wenn du Zugriff hast könntest ja mal die aktuelle laden, sobald du wieder die Vorlagen im AdminCenter öffnen möchtest (also die site). Vielleicht steht im ErrorLog was drin was hilft  


--


In einen anderen Forum meinte jemand das der Anbieter helfen könnte bzw. das ein Problem des Servers selbst sei. Da hies es aber das dies nur temporär sei - also nach ein paar Tagen wieder normal läuft  


Ansonsten wüsst ich nicht weiter  verwirrt


 
Zum Anfang der Seite
01.12.2015 - 18:59 Uhr
Beitrag: #9
Hab mal die log Datei gekuckt.
Kann aber nichts damit anfangen.




1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26

Quellcode

[01-Dec-2015 17:53:22 Europe/LondonPHP Notice:  Use of undefined constant Code assumed 'Code' in /home/tournlu1/public_html/pkinc/cfg/bbcode.php on line 116
[01-Dec-2015 17:53:22 Europe/LondonPHP Notice:  Undefined indexscatid in /home/tournlu1/public_html/pkinc/func/default.php on line 2060
[01-Dec-2015 17:53:22 Europe/LondonPHP Notice:  Undefined variableaddsqlcommand in /home/tournlu1/public_html/pkinc/func/default.php on line 2067
[01-Dec-2015 17:53:22 Europe/LondonPHP Notice:  Undefined variableopen in /home/tournlu1/public_html/pkinc/class/bbcode.php on line 205
[01-Dec-2015 17:53:22 Europe/LondonPHP Notice:  Undefined variableclosed in /home/tournlu1/public_html/pkinc/class/bbcode.php on line 211
[01-Dec-2015 17:53:22 Europe/LondonPHP Notice:  Undefined variableopen in /home/tournlu1/public_html/pkinc/class/bbcode.php on line 205
[01-Dec-2015 17:53:22 Europe/LondonPHP Notice:  Undefined variableclosed in /home/tournlu1/public_html/pkinc/class/bbcode.php on line 211
[01-Dec-2015 17:53:22 Europe/LondonPHP Notice:  Undefined variableopen in /home/tournlu1/public_html/pkinc/class/bbcode.php on line 205
[01-Dec-2015 17:53:22 Europe/LondonPHP Notice:  Undefined variableclosed in /home/tournlu1/public_html/pkinc/class/bbcode.php on line 211
[01-Dec-2015 17:53:22 Europe/LondonPHP Notice:  Undefined variableopen in /home/tournlu1/public_html/pkinc/class/bbcode.php on line 205
[01-Dec-2015 17:53:22 Europe/LondonPHP Notice:  Undefined variableclosed in /home/tournlu1/public_html/pkinc/class/bbcode.php on line 211
[01-Dec-2015 17:53:22 Europe/LondonPHP Notice:  Undefined variablecontent_text in /home/tournlu1/public_html/pkinc/public/content.php on line 252
[01-Dec-2015 17:53:22 Europe/LondonPHP Deprecated:  Function eregi() is deprecated in /home/tournlu1/public_html/pkinc/public/content.php on line 255
[01-Dec-2015 17:53:22 Europe/LondonPHP Notice:  Undefined variableopen in /home/tournlu1/public_html/pkinc/class/bbcode.php on line 205
[01-Dec-2015 17:53:22 Europe/LondonPHP Notice:  Undefined variableclosed in /home/tournlu1/public_html/pkinc/class/bbcode.php on line 211
[01-Dec-2015 17:53:22 Europe/LondonPHP Notice:  Undefined variablecontent_teaser in /home/tournlu1/public_html/pkinc/public/content.php(280) : eval()'d code on line 7
[01-Dec-2015 17:53:22 Europe/London] PHP Notice:  Undefined variable: content_pagelink in /home/tournlu1/public_html/pkinc/public/content.php(280) : eval()'
d code on line 13
[01-Dec-2015 17:53:22 Europe/LondonPHP Notice:  Undefined variablepos in /home/tournlu1/public_html/pkinc/public/contentwrapper.php on line 109
[01-Dec-2015 17:53:22 Europe/LondonPHP Deprecated:  Function eregi() is deprecated in /home/tournlu1/public_html/pkinc/public/content.php on line 255
[01-Dec-2015 17:53:22 Europe/LondonPHP Notice:  Undefined variablecontent_teaser in /home/tournlu1/public_html/pkinc/public/content.php(280) : eval()'d code on line 7
[01-Dec-2015 17:53:22 Europe/London] PHP Notice:  Undefined variable: content_pagelink in /home/tournlu1/public_html/pkinc/public/content.php(280) : eval()'
d code on line 13
[01-Dec-2015 17:53:22 Europe/LondonPHP Notice:  Undefined variablesite_body_headTicker in /home/tournlu1/public_html/pkinc/public/newsticker.php(28) : eval()'d code on line 5
[01-Dec-2015 17:53:22 Europe/London] PHP Notice:  Undefined variable: ksTabDesign in /home/tournlu1/public_html/pkinc/public.php(271) : eval()'
d code on line 337
[01-Dec-2015 17:53:22 Europe/LondonPHP Notice:  Undefined variablelogo_link in /home/tournlu1/public_html/pkinc/public.php(271) : eval()'d code on line 337
[01-Dec-2015 17:53:22 Europe/London] PHP Notice:  Undefined variable: popup in /home/tournlu1/public_html/pkinc/public.php(271) : eval()'
d code on line 443
[01-Dec-2015 17:53:23 UTCPHP Notice:  Undefined variablestyle_width in /home/tournlu1/public_html/pkinc/class/style.php on line 135


 
Zum Anfang der Seite
02.12.2015 - 17:25 Uhr
Beitrag: #10
Die ErrorLog sagt aber auch rein gar nichts aus worauf eine 404-Meldung schließen würde  

Also mir fällt nichts mehr ein. Keine Ahnung wo da ein Fehler sein soll. Da müsst man wahrscheinlich das mal irgendwie Live sehen und entsprechend den einen oder anderen Test machen. Ist mir sowieso schleierhaft warum gerade nur die Vorlage side oder im AdminCenter der Konfigurations-Teil für Meta-Angaben nicht will.


Ich mein:
Es besteht doch nur im Vorlagen-Bereich beim Eintrag side und bei Konfiguration > Meta-Angaben das Problem, oder?



Kannst du nicht probehalber nochmal andere Bereiche prüfen (und hier mal grob oder detaliert auflisten)? Also z.B. welchen Bereich du geöffnest hast, ob dieser zu öffnen war, konnte der Speicher-Button betätigt werden.
Kommt die 404-Meldung direkt nachdem du die Vorlage side editieren willst, oder kannste den Editierungsbereich öffnen aber sobald du auf den Speicher-Button drückst kommt die 404-Meldung?
Kannst du andere Bereiche bei der Konfiguration öffnen und speichern?

Für mich klingt das einfach nicht logisch, das (nur?) 2 Bereiche eine 404-Meldung angeben, die restlichen Bereiche aber nicht. Zumal beim Vorlagen-Bereich nur die side nicht will -> "was ist an der anders?" würd ich mich fragen ^^"


 
Zum Anfang der Seite
02.12.2015 - 18:51 Uhr
Beitrag: #11
Ich verstehs ja auch nicht. Hab dir mal per IM ein Adminaccount ertellt. Kannst es dir ja dann selbst ansehn. Ich bin mit meinem Latein am Ende.
Hab den PKSM mal abgestellt. Sonst geht es ja auch nicht.

EDIT:
Bei content/content kann ich bei den Vorlagen bearbeiten.
Die galerie/main_out_modern_1 auch.
Die galerie/pic dagegen macht eine Fehlermeldung.
Die navigation/content_box_left geht.
Die site geht dagegen wieder nicht......  

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Nueschtmanescht - 02.12.2015 - 18:57 Uhr
 
Zum Anfang der Seite
03.12.2015 - 18:00 Uhr
Beitrag: #12
So, hab mal geguckt. Kannst den Account wieder löschen oder so ;o

Hab ein paar Sachen rumprobiert (einfacher "Auf Speichern klicken"-Test) und dachte erst, das in den Dateien irgendwas gefiltert wird. Hab also ein paar Sachen im Vorlagenbereich probiert und dachte ich find was. Aber konnte mir keinen Reim drauf machen  

Durch eher Zufall hab ich dann mal den Abrechen-Button geklickt.
Und siehe da:
Bei einer Vorlage, wo keine Meldung kommt, wird ordnungsgemäß zurück zur Übersicht geleitet.
Wenn ich allerdings eine Vorlage mit Abrechen-Button anklicke erscheint die Meldung.


Daher glaube ich das es nicht am PHPKit selbst liegt, sondern das der Server irgendein Problem mit den verarbeiten von Formular-Anweisungen hat. Weiss ja nicht was der Server (also im allgemeinen) bei Formularen so verarbeitet  
Aber naja, ich denke, das liegt wirklich irgendwie eher mit dem Server zusammen als mit dem PHPKit. Oder irgendein anderes Problem - k.A. .. Die ErrorLog ergab ja nichts verwertbares  


Davon aber mal abgesehen:
Dein eigentliches anliegen war ja die CookieBar einzupflegen. Hat das noch Zeit, hat also keine große Priorität, oder sollte das dennoch jetzt irgendwie rein?

Ich mein, es gibt ja noch andere Wege dies zu tun.
Hab im Anhang mal eine TEST.php - die kopierste in den pkinc/public/-Ordner und öffnest dann einfach die Seite http://www.touren.lu/include.php?path=TEST

Dort kannste den Code in ein Textfeld eingeben und dieser wird dann in die Datenbank gespeichert.
Die Datei kannst danach löschen, verschieben, dort lassen - wies dir beliebt. Zugriff hast nur du - jeder andere wird zur Startseite umgeleitet.
Und es erfolgt keine Meldung ob Fehler oder Speicherung korrekt war - ist mir jetzt zuviel aufwand ^^""

Aber vielleicht kannste so zumindest schon mal eigentliche Anliegen abhaken ^^"


 
Zum Anfang der Seite
27.12.2015 - 15:43 Uhr
Beitrag: #13
Hallo

Etwas spät aber ich hatte eher leider keine Zeit zum Testen.

Wenn ich den Code eingebe kommt folgende Fehlermeldung:

--------------------------

Forbidden

You don't have permission to access /include.php on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.


Kann man nicht über FTP an die content/site ?

 
Zum Anfang der Seite
30.12.2015 - 19:48 Uhr
Beitrag: #14
Hallo k!r!ka

Das Thema hat sich erledigt.
Die Firewall des Servers soll, laut Provider, die Ursache gewesen sein.

Vielen lieben Dank für deine Hilfe.
Ein guten Rutsch ins neue Jahr.

 
Zum Anfang der Seite
 Seiten (1):    1  

Ähnliche Themen
 
Plauderecke Plauderecke » Herzlich Willkommen, cookie - Letzte Antwort von BOTTY am 01.05.10, 15:35 Herzlich Willkommen, cookie  (01.05.10, 15:35)
HTML HTML » Anker setzen - Letzte Antwort von DHH am 02.03.16, 12:04 Anker setzen  (02.03.16, 12:04)
Support Support » Newsticker direkt unter das Banner setzen ?? Wie ??? - Letzte Antwort von thrinition am 31.01.08, 01:05 Newsticker direkt unter das Banner setzen ?? Wie ?..  (31.01.08, 01:05)
Fragen und Antworten Fragen und Antworten » Kann Verweise im ACP nicht von Gast auf einen andren Status setzen.. - Letzte Antwort von pitBull_i7 am 24.02.13, 14:57 Kann Verweise im ACP nicht von Gast auf einen andr..  (24.02.13, 14:57)

HTH-C.com - Webmedien & Community