HTH-C.com - Forum
Latest News Latest Threads
Neuerung: Persönliche Galerie
Informationen zur Übernahme der Erweite..
HTH Blog - Version 2.0
#HTH.Systems - Betatester gesucht
Neueröffnung - PHPKit-Award.de
HTH Webchat v3
Letzter Beitrag Happy Birthday Bottyline Weiblicher Benutzer Heute, 0:00 Zeit der letzten Antwort
Letzter Beitrag Gibt es eigentlich noch jemand der PHPki.. Treffnix Männlicher Benutzer Gestern, 14:04 Zeit der letzten Antwort
Letzter Beitrag PHPKit 1.6.6 Treffnix Männlicher Benutzer Gestern, 13:55 Zeit der letzten Antwort
Letzter Beitrag Herzlich Willkommen Botty Männlicher Benutzer Gestern, 13:50 Zeit der letzten Antwort
Letzter Beitrag PHPKit 1.6.6 ohne ASCE auf PHP8x Myrddin Männlicher Benutzer 22.03.2023 - 12:36 Zeit der letzten Antwort
 53.115 Posts & 4.945 Themen in 78 Foren
Forenübersicht » HTH Community » Fragen und Antworten » Chapta und Usermap Problem

Chapta und Usermap Problem
31 Beiträge in diesem Thema
 Seiten (3):    1     2     3    Next    >  
28.01.2013 - 17:22 Uhr
Beitrag: #1
Hallo,

also, ich habe das phpKit nun 3 mal für verschiedene Webseiten installiert.

Die ersten beiden Kit´s gehen mit allem einwandfrei.

Nur beim letzten Kit habe ich 2 Probleme, obwohl ich die Erweiterungen genauso
eingebaut habe wie bei den ersten Beiden.

1. Problem Captcha:

Wenn ich Captcha im ACP aktiviere, erscheint auch überall das Chapta Bild.
Nur ist kein Code zu sehen. Also keine Schrift.

2. Problem:

Das Gleiche habe ich auch in der UserMap, dort werden mir die Städte auf dem Bild
nicht angezeigt und die User nicht, auch die Punkte nicht.

Nein, ich habe nichts falsch editiert.

Kann das am Style liegen?
Was ich nicht glaube, habe dann ein Standartstyle von Kit aktiviert und da ging auch beides nicht.

Könnt ihr mir bitte mal schreiben, in welchen Dateien ich nachsehen muss?

Habe wirklich alles durchsucht, komme aber nicht drauf, weil in den Tpl`s meist immer nur
$captcha steht aber kein Hinweis auf die dazugehörenden PHP- Dateien

Ich frage hier deswegen nach der UserMap, weil es für diese auf den DL Seiten kein Support mehr gibt.
Ich denke aber nicht, das es an UserMap liegt.

Ehe ich es vergesse, in den Datenbanken ist alles vorhanden.
Habe auch per phpinfo alle 3 Webseiten die Server php Einstellungen verglichen, alle 3 gleiche.

mfg

neumicha

Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von neumicha - 29.01.2013 - 17:56 Uhr
 
Zum Anfang der Seite
28.01.2013 - 18:01 Uhr
Beitrag: #2
Klingt nach einem GDLib Problem.
Die Einstellungen der Server sind sicher die selbigen?

Bitte einmal das Archiv im Anhang herunterladen, die sich darin befindene Datei auf den Server laden und jene aufrufen.
meinedomain.tld/gdtest.php

PS: Captcha hört sich etwas besser an.    Bääääh

 
Zum Anfang der Seite
28.01.2013 - 18:09 Uhr
Beitrag: #3
Hallo Webi,

danke für die Datei, folgendes Ergebnis schreibt der raus:

Unterstützte Grafikformate:
GIF-Unterstützung ist vorhanden.
JPG-Unterstützung ist vorhanden.
JPEG-Unterstützung ist vorhanden.
PNG-Unterstützung ist vorhanden.
WBMP-Unterstützung ist vorhanden.

mfg

neumicha

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von neumicha - 29.01.2013 - 17:58 Uhr
 
Zum Anfang der Seite
30.01.2013 - 16:13 Uhr
Beitrag: #4
Hallo,

ich habe men Anbieter angerufen, der hat dann was an gblib rumgestellt, ging aber immer noch nicht.

Dann habe ich Kit in einem Unterordner aufgespielt und da ging das Captcha aber die Usermap immer noch nicht.

Jetzt vermute ich, dass ich beim Captcha was kaputt gemacht habe. Wo ich suchen könnte weiß ich leider nicht.

Was die UserMap angeht, so könnte es sein, dass es noch an der Servereinstellung liegt.

Das komische ist, die Entfernungsabfrage, User aus deiner Plz und die Plz abfrage in der
Userinfo funktioniert einwandfrei, die UserMap zieht ja auch ihre Daten aus dem PLZ Feld.

mfg

neumicha

 
Zum Anfang der Seite
30.01.2013 - 16:55 Uhr
Beitrag: #5
  • UserMap
    Hmm .. Keine Ahnung, kenn das Teil ansich nicht. Hättest vielleicht einen Download-Link für deine Version?;o

    Ach ja, die User in deiner Gegend muss nicht auf die selbe Weise arbeiten. Auch berechnet diese ja die Entfernung, bei der UserMap muss ja eigentlich nur der Standort auf der Karte fixiert werden ;o

  • Captcha
    Also wenn GDLib aktiv, die Bilder ansich auch gezeigt werden, dann kann ansich ja nur eins nicht stimmen. Die Schriftart selbst ist nicht dort, wo sie hätte sein sollen. Und zwar guck einfach mal nach, ob an folgender Stelle eine Schriftart-Datei liegt:

    • pkinc/rep/gdfx/fonts/xfiles.ttf

    Sollte dort die Schriftart-Datei sein, dann könnte nur noch an einer .php-Datei gebastelt worden sein. Beispielweise diese: pkinc/media.php


 
Zum Anfang der Seite
30.01.2013 - 17:19 Uhr
Beitrag: #6
Hallo k!r!ka,

danke dir, tatsächlich, xfiles.ttf war nicht vorhanden.

Ich habe aber in der pkinc/rep/gdfx/fonts nie was gemacht.
Das Einzige, was ich vermuten kann ist, dass beim upload nicht alles mit auf den Server kam.

Manchmal hatte mein FileZilla mittendrin einen ausfall, nun geht wenigstens das Captcha.

Nur mit der UserMap halt noch nicht, hat die vielleicht auch eine ttf Datei wo die drauf zugreift?

Als Anhang die Usermap

mfg

neumicha

 
Zum Anfang der Seite
30.01.2013 - 19:54 Uhr
Beitrag: #7
Ich hab mir die UserMap mal kurz angeguckt. Und wenn ich das richtig gesehen habe, werden nur für die User und Städte eine Funktion benutzt, die eine gewisse GD-Version benötigt. Es kann also sein, das der Server diese GD-Version nicht installiert hat. Um das prüfen zu können, habe ich im Anhang eine Datei gepackt, die genau das prüfen soll. Du wirst an den Text merken, ob alles okay ist  

Es ist halt eine Vermutung, dies muss das Problem jetzt nicht beseitigen können.
Ach ja, zur Benutzung der Datei:
Einfach auf den Server laden und direkt aufrufen. Oder, wenn du magst, kannst es auch über das phpKit laden lassen. Dann kommt die Datei einfach in den pkinc/public/-Ordner und dann via. ?path=gd_info aufrufen lassen.


Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von k!r!ka - 30.01.2013 - 19:56 Uhr
 
Zum Anfang der Seite
30.01.2013 - 20:16 Uhr
Beitrag: #8
Hallo k!r!ka,

die gleiche Datei hat mir schon Webi gesendet und ich habe das Ergebnis
hier in diesem Thread schon gepostet.

Habe es eben aber nochmal gemacht, hier das Ergebnis:

Unterstützte Grafikformate:
GIF-Unterstützung ist vorhanden.
JPG-Unterstützung ist vorhanden.
JPEG-Unterstützung ist vorhanden.
PNG-Unterstützung ist vorhanden.
WBMP-Unterstützung ist vorhanden.


mfg

neumicha

 
Zum Anfang der Seite
30.01.2013 - 20:21 Uhr
Beitrag: #9
Falsch, denn meine prüft auf die GD Unterstützung einzelner Grafik-Typen, k!r!ka seine auf die erforderliche Version, für die Usermap. Also einfach herunterladen, hochladen und aufrufen. zwinkern

 
Zum Anfang der Seite
30.01.2013 - 20:24 Uhr
Beitrag: #10
Mir ist bewusst, das WEBI bereits eine Datei mit einer Prüfung angehängt hat. Meine angehängte Datei hat aber eine ganz andere Prüfung inne. Wie ich bereits kurz gesagt habe, werden, sofern ich micht da jetzt nicht verguckt habe, die Städte sowie User über eine spezielle Funktion aufgerufen. Diese spezielle Funktion ist erst ab einer gewissen GD-Version verfügbar. Und genau das prüft die angehängte Datei: Hat dein Server die nötige Version drauf - ja / nein.

Und dieses ja / nein wird auch entsprechend in der Datei ausgegeben. Es soll mir halt nur sagen, ob ich weiter in der UserMap suchen muss, oder es einfach ein GD-Versions-Problem ist.


 
Zum Anfang der Seite
30.01.2013 - 20:26 Uhr
Beitrag: #11
Hallo webi,
hab ich gemacht, dann hat mir k!r!ka
die falsche Datei zukommen lassen oder es geht bei mir nicht

es war in dem DL die Datei gdtest, die gleiche wie von dir.

mfg

neumicha

 
Zum Anfang der Seite
30.01.2013 - 20:28 Uhr
Beitrag: #12
Dann nutze notfalls folgenden Code:
- Dem Archiv entnommen - gd_info.php



1
2
3
4
5
6
7
8
9
10
11
12
13
14
15

PHP-Quelltext

<?php
$gd
=gd_info();
echo 
'<pre>';
echo
    
$gd['GD Version'] < '2.0.28'
    
'<span style="color: red;">Tut mir Leid, deine GD-Version ist unter der geforderten Version von 2.0.28  unglücklich</span>'
    
'<span style="color: green;">Strike, deine GD-Version ist über der nötigen 2.0.28 installiert ;o</span>'
    
;
echo 
"\n";
echo 
"\n";
echo 
'Hier nochmal die Daten von der installierten GD-Librarie deines Servers:';
echo 
"\n";
print_r($gd);
echo 
'</pre>';
?>


 
Zum Anfang der Seite
30.01.2013 - 20:29 Uhr
Beitrag: #13
Falsch? Also wenn ich den Anhang lade, krieg ich die, die ich hochgeladen habe  

Naja, hier nochmal der Code selbst:
Code-Block entfernt, der olle WEBI war schneller  k!r!ka


Dateiname ist egal ;o Hauptsache mit der Endung .php ;o


Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von k!r!ka - 30.01.2013 - 20:29 Uhr
 
Zum Anfang der Seite
30.01.2013 - 20:31 Uhr
Beitrag: #14
sodele nun aber richtig,

habe mich vertan, sorry dafür.

hier das ergebnis:

Tut mir Leid, deine GD-Version ist unter der geforderten Version von 2.0.28  unglücklich

Hier nochmal die Daten von der installierten GD-Librarie deines Servers:
Array
(
[GD Version] => 2.0
[FreeType Support] => 1
[FreeType Linkage] => with freetype
[T1Lib Support] => 1
[GIF Read Support] => 1
[GIF Create Support] => 1
[JPEG Support] => 1
[PNG Support] => 1
[WBMP Support] => 1
[XPM Support] =>
[XBM Support] =>
[JIS-mapped Japanese Font Support] =>
)

 
Zum Anfang der Seite
30.01.2013 - 20:35 Uhr
Beitrag: #15
Wie ich mir fast schon dachte. Die erwähnte Funktion ist erst ab GD-Version 2.0.28 verfügbar. Und bei dir scheint noch die 2.0 installiert zu sein. Da diese Funktion hauptsächlich für die User und Städte gebraucht wird, werden natürlich jene nicht gezeigt, da nicht verarbeitet werden konnte ô.o


 
Zum Anfang der Seite
 Seiten (3):    1     2     3    Next    >  

Ähnliche Themen
 
Support Support » Problem mit Usermap - Letzte Antwort von bcm4web am 31.08.07, 15:52 Problem mit Usermap  (31.08.07, 15:52)
Support Support » Problem bei Usermap installation - Letzte Antwort von Noob am 12.06.07, 18:18 Problem bei Usermap installation  (12.06.07, 18:18)
Support Support » Eine Frage zur Usermap (usermap.js) - Letzte Antwort von WEBI am 02.01.08, 12:54 Eine Frage zur Usermap (usermap.js)  (02.01.08, 12:54)
Support Support » UserMap - Letzte Antwort von Turkos am 29.05.07, 19:46 UserMap  (29.05.07, 19:46)
Support Support » Usermap - Letzte Antwort von Lappi am 06.06.07, 16:03 Usermap  (06.06.07, 16:03)

HTH-C.com - Webmedien & Community